WebRTC は、ブラウザーどうしなどが、音声、映像、データをリアルタイムにやり取りするための技術です。IETF が定める通信のプロトコルと、W3C が定める JavaScript の API の2つからなります。
W3C の API の仕様「WebRTC: Real-Time Communication in Browsers」は、2021年1月26日に W3C 勧告になり、その後も更新されています。2026年10月時点の版は、2025年3月13日付です。IETF の側の全体像は、RFC 8825(2021年1月)にまとめられています。
RFC 9317 は、遅延の目標が1秒未満の用途の多くは、RTP や WebRTC を使うと説明しています。WebRTC でストリーミングのサービスや CDN へ映像を送り込むための手順は、WHIP(WebRTC-HTTP Ingestion Protocol。RFC 9725、2025年3月)として定められています。
- 正式な名前
- Web Real-Time Communication
- 業界
- 製造業、小売・流通、医療・福祉、建設、金融・保険、教育機関
- 業務
- 動画、規格と法規制
- 出典の確認日
